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Voice Editor II is a DOS-based application that allows you to record and 
edit voice files.  With voice Editor II, you can cut away unwanted or 
unnecessary sounds from a voice file without removing important 
information. 
 
RUNNING VOICE EDITOR II 
 
To run Voice Editor II: 
 
1.  Change to \SBPRO\VEDIT2 sub-directory. 
 
2.  Type VEDIT2 [/B:nn] and press <ENTER>. 
    A window displaying information about the application appears. 
 
The command line parameter is as follows: 
 
┌─────────┬─────────────────────────────────────────────────────────────┐ 
│PARAMETER│DESCRIPTION                                                  │ 
├─────────┼─────────────────────────────────────────────────────────────┤ 
│/B:nn    │This optional parameter allows you to set the buffer size for│ 
│         │playing from disk by entering a number for NN in 2K units.   │ 
│         │The default for NN is 16, making the buffer size 32 Kbytes.  │ 
│         │You get a smoother sound if the buffer size is bigger.       │ 
└─────────┴─────────────────────────────────────────────────────────────┘ 
 
USING THE KEYBOARD AND MOUSE 
 
You can use the keyboard or a mouse to perform various operations, in 
Voice Editor II.  As there are many ways of using the two devices, only 
the basic operation for selecting the menu commands will be specified. 
Other ways of using the keyboard and mouse to access the menu command 
will be specified when required. 
 
TO ACCESS THE MENU COMMANDS USING THE KEYBOARD 
 
1.  Press <ALT> and the underlined letter of the desired menu on the menu 
    bar. 
 
2.  Press the underlined letter to select the desired command. 
 
NOTE:  When selecting the commands on the menu, you can also use the 
       arrow keys and <ENTER> to confirm the selection. 
 
TO ACCESS MENU OPTIONS USING A MOUSE: 
 
1.  Click once on the desired menu from the menu bar. 
 
2.  Click again to select the desired menu command. 
 
THE VOICE EDITOR II MENUS 
 
There are seven menus on Voice Editor II.  They are File, Record, Play, 
Pack, Edit CDisk, and Volume. 
 
THE FILE MENU 



 
The descriptions of the commands on the File menu are: 
┌───────┬─────────────────────────────────────────────────────┐ 
│COMMAND│DESCRIPTION                                          │ 
├───────┼─────────────────────────────────────────────────────┤ 
│Load   │Loads a voice file into memory.                      │ 
├───────┼─────────────────────────────────────────────────────┤ 
│Save   │Saves changes made to the voice file.                │ 
├───────┼─────────────────────────────────────────────────────┤ 
│Save As│Saves changes made to the voice file with a new name.│ 
├───────┼─────────────────────────────────────────────────────┤ 
│Write  │Saves only selected blocks to a voice file.          │ 
├───────┼─────────────────────────────────────────────────────┤ 
│Intro  │Displays the copyright screen.                       │ 
├───────┼─────────────────────────────────────────────────────┤ 
│Exit   │Quits Voice Editor II.                               │ 
└───────┴─────────────────────────────────────────────────────┘ 
 
THE RECORD MENU 
 
The descriptions of the commands on the Record menu are: 
 
┌──────────┬────────────────────────────────────────────────────────┐ 
│COMMAND   │DESCRIPTION                                             │ 
├──────────┼────────────────────────────────────────────────────────┤ 
│Settings  │Sets the sampling rate and the location for storing the │ 
│          │recording.                                              │ 
├──────────┼────────────────────────────────────────────────────────┤ 
│To Memory │Stores the recorded data in system memory.              │ 
├──────────┼────────────────────────────────────────────────────────┤ 
│To Disk   │Stores the recorded data in disk.                       │ 
├──────────┼────────────────────────────────────────────────────────┤ 
│Scan Input│Scans the recorded data and displays it on the Scan     │ 
│          │Input window.                                           │ 
└──────────┴────────────────────────────────────────────────────────┘ 
 
THE PLAY MENU 
 
The descriptions of the commands on the Play menu are: 
 
┌─────────────────┬───────────────────────────────────────────┐ 
│COMMAND          │DESCRIPTION                                │ 
├─────────────────┼───────────────────────────────────────────┤ 
│From Memory      │Plays a voice file from system memory.     │ 
├─────────────────┼───────────────────────────────────────────┤ 
│Selectable Block │Plays only selected blocks of a voice file.│ 
├─────────────────┼───────────────────────────────────────────┤ 
│Disk             │Plays a voice file from disk.              │ 
└─────────────────┴───────────────────────────────────────────┘ 
 
THE PACK MENU 
 
The descriptions of the commands on the Pack menu are: 
 
┌───────┬───────────────────────────────────┐ 
│COMMAND│DESCRIPTION                        │ 
├───────┼───────────────────────────────────┤ 



│Memory │Compresses voice files from memory.│ 
├───────┼───────────────────────────────────┤ 
│Disk   │Compresses voice files from disk.  │ 
└───────┴───────────────────────────────────┘ 
 
THE EDIT MENU 
 
The descriptions of the commands on the Edit menu are: 
 
┌───────┬──────────────────────────────────────────────────────────────┐ 
│COMMAND│DESCRIPTION                                                   │ 
├───────┼──────────────────────────────────────────────────────────────┤ 
│Insert │Adds blocks of information to an existing voice file.         │ 
├───────┼──────────────────────────────────────────────────────────────┤ 
│Delete │Deletes blocks of information from an existing voice file.    │ 
├───────┼──────────────────────────────────────────────────────────────┤ 
│Modify │Modifies blocks of information from an existing voice file.   │ 
├───────┼──────────────────────────────────────────────────────────────┤ 
│Move   │Moves selected blocks of information to a different location. │ 
├───────┼──────────────────────────────────────────────────────────────┤ 
│Copy   │Copies selected blocks and moves them to a different location.│ 
├───────┼──────────────────────────────────────────────────────────────┤ 
│Combine│Combines voice block having the same sampling rate.           │ 
└───────┴──────────────────────────────────────────────────────────────┘ 
 
THE CDISK MENU 
 
The description of the command on the CDisk menu is: 
 
┌─────────┬───────────────────┐ 
│COMMAND  │DESCRIPTION        │ 
├─────────┼───────────────────┤ 
│CD Player│Runs the CD Player.│ 
└─────────┴───────────────────┘ 
 
THE VOLUME MENU 
 
The descriptions of the commands on the Volume menu are: 
 
┌───────┬───────────────────────────┐ 
│COMMAND│DESCRIPTION                │ 
├───────┼───────────────────────────┤ 
│Master │Controls master volume.    │ 
├───────┼───────────────────────────┤ 
│Voice  │Controls digitized sound.  │ 
├───────┼───────────────────────────┤ 
│CDisk  │Controls CD-audio.         │ 
├───────┼───────────────────────────┤ 
│Line In│Controls audio line-in.    │ 
└───────┴───────────────────────────┘ 
 
SELECTING BLOCKS 
 
Before editing or playing a Voice block, it is necessary to know how to 
select a block.  Block selecting is made on the Block Type Information 
window using the keyboard or a mouse.  You can select more than one block 
at a time.  However, the blocks selected must be next to each other. 



 
TO SELECT MORE THAN ONE BLOCK USING THE MOUSE: 
 
1.  Click and hold down the left mouse button on the desired block. 
 
2.  Drag the mouse to the block you want to select. 
 
3.  Release the left mouse button. 
 
The blocks selected will be enclosed in a double-rule box. 
 
TO SELECT MORE THAN ONE BLOCK USING THE KEYBOARD: 
 
1.  Press <B>. 
 
    This activates the Blk Bgn test box on the right of the Block Type 
    Information window. 
 
2.  Type the number of the starting block and press <ENTER>. 
 
3.  Press <F>. 
 
    This activates the Blk End test box on the right of the Block Type 
    Information window. 
 
4.  Type the number of the ending block and press <ENTER>. 
 
    The current block is highlighted and the block selected will be 
    enclosed in a double-rule box. 
 
TO SELECT BLOCKS QUICKLY USING THE KEYBOARD: 
 
1.  Press <CRTL+B> at the current block to mark the beginning block. 
 
2.  Move the highlighted block using the up or down arrow to the ending 
    block. 
 
3.  Press <CTRL+E> to mark the ending block. 
 
NOTE:  Terminator block cannot be selected. 
 
LOADING LARGE FILES 
 
Since recorded files can be as large as available disk space, some files 
may be too large to load into memory.  To overcome this limitation, Voice 
Editor II provides a method that allows you edit a portion of the file at 
a time.  When a file is loaded, two windows appear. 
 
The features on both windows allow you to modify the file so that it can 
be loaded into memory.  To modify the file, you must split the file and 
than edit the split block. 
 
TO SPLIT A FILE TOO LARGE FOR MEMORY: 
 
1.  Select the desired block from the Block Type Information window. 
 
2.  Select the Split button from the Message window. 



 
TO EDIT A BLOCK: 
 
1.  Select the desired block from the Block Type Information window. 
 
2.  Select the OK button from the Block Type Information window. 
    The Block Type Information window appears listing the blocks 
    selected. 
 
3.  To edit the block, select the desired command on the Edit menu. 
 
SELECTING RECORDING SETTINGS 
 
To select the recording settings: 
 
1.  Select Setting from the Record menu. 
 
2.  Select the desired settings. 
 
-Select 8 or 11 kHz for voice-quality sound sampling, 22.05 kHz for 
 AM-quality sampling rate, and 44.1 kHz for audio CD-quality sampling 
 rate. 
 
-Select Low Filter for sampling rate below 18 kHz, High Filter for 
 sampling rate between 18 kHz and 36 kHz, and No filter for sampling rate 
 above 36 kHz. 
 
-Select Stereo if the recording source supports stereo mode. 
 
3.  Choose OK. 
 
NOTE:  Generally, the higher the sampling rate, the better the recording 
       quality. 
 
SCANNING AUDIO INPUT 
 
1.  Select Scan Input from the Record menu. 
 
    The Scan Input window displaying an active waveform appears.  (If you 
    are using a microphone, you need to speak into it before you can see 
    the waveform). 
 
2.  Once you are satisfied with the input, press <ESC> or click the left 
    mouse button to remove the Scan Input window. 
 
CREATING A RECORDING 
 
Once the appropriate settings have been made, a recording can be made. 
You can either record to memory or disk.  When you are recording to 
memory, make sure the recording is not too large because you only have 
a certain amount of available system memory. 
 
TO RECORD TO MEMORY: 
 
1.  Select to Memory from the Record menu. 
 
    The Voice dialog box appears. 



 
2.  Select the Stop button to finish the recording. 
 
When the recording is completed, the Block Information Type window will 
display a new Block Type Information window. 
 
TO RECORD TO DISK: 
 
1.  Select to Disk from the Record menu. 
 
    The Record to File dialog box appears. 
 
2.  Type in the name of the file in the Filename text box. 
 
3.  Choose OK. 
 
NOTE:  If you select an existing filename, you will be asked if you want 
       to overwrite the file. 
 
PLAYING A RECORDING 
 
You can play back your recording from the disk, memory, or selected 
blocks. 
 
TO PLAY A RECORDING FROM MEMORY 
 
1.  Load a file from disk into memory. 
 
2.  Select From Memory from the Play menu. 
 
    The Voice dialog box appears. 
 
3.  Select the Stop button to stop playing from memory. 
 
TO PLAY A RECORDING FROM DISK 
 
1.  Select From Disk from the Play menu. 
 
    The Play File dialog box appears. 
 
2.  Select the desired file. 
 
3.  Choose OK. 
 
    The Voice dialog box appears. 
 
4.  Select the Stop button to stop playing from disk. 
 
TO PLAY A RECORDING FROM SELECTED BLOCKS: 
 
1.  Select any combination of blocks from the Block Type Information 
    window. 
 
2.  Select Selected Blocks from the Play menu. 
 
3.  Select the Stop button to stop playing the selected blocks. 
 



EDITING VOICE FILES 
 
You can edit a voice file in the Block Type Information window using the 
commands on the Edit menu. 
 
TO INSERT A BLOCK 
 
1.  Select the desired block. 
 
2.  Select Insert from the Edit menu. 
 
    The insert dialog box appears. 
 
3.  Select the desired block from the Insert dialog box. 
 
    A dialog box appears. 
 
4.  Choose OK. 
 
    The block you inserted will be displayed on the block Type 
    Information window. 
 
TO DELETE A BLOCK 
 
1.  Select the desired block on the Block Type Information window. 
 
2.  Select Delete from the Edit menu. 
 
    The Delete dialog box appears. 
 
3.  Choose Yes to confirm or No to stop the deletion. 
 
    If no blocks are selected, you will be asked whether you want to 
    delete the current block. 
 
TO MOVE A BLOCK 
 
1.  Select the desired block. 
 
    The block selected will be enclosed in a box. 
 
2.  Select the location to move the block to. 
 
    The new location will be indicated by a highlighted block. 
 
3.  Select Move from the Edit menu. 
 
    The block will be moved to the new location. 
 
TO COPY A BLOCK 
 
1.  Select the desired block. 
 
    The block selected will be enclosed in a box. 
 
2.  Select the location to copy the block to. 
 



    The new location will be indicated by a highlighted block. 
 
3.  Select Copy from the Edit menu. 
 
    The selected block will be copied to the new location. 
 
TO COMBINE BLOCKS: 
 
1.  Select the desired blocks. 
 
2.  Select Combine from the Edit menu. 
 
    The selected blocks will be combined. 
 
NOTE:  Only voice blocks can be combined. 
 
COMPRESSING VOICE BLOCKS 
 
Voice Editor II allows a voice block to be compressed in rations of 4:1, 
3:1 and 2:1.  The 4:1 ratio reduces the size of the voice block by 75%, 
3:1 by 66% and 2:1 by 50%.  A compressed voice block is reflected in the 
Block Type Information window with the label PK1, PK2, or PK3. 
 
To compress a Voice Block: 
 
1.  Select a Voice block from the Block Information Screen. 
 
2.  Select Memory or Disk from the Pack menu. 
 
3.  Select the desired compression ratio. 
 
CHANGING THE CHARACTERISTICS OF VOICE BLOCKS 
 
You can change the shape and characteristics of a voice block by using 
Modify from the Edit menu.  When the modify option is selected, the 
Editing Voice Data window appears. 
 
The window displays the Voice block as a waveform.  Three menus available 
for selections are Option, Edit, and Effect.  The descriptions of the 
menus are: 
 
┌──────┬────────────────────────────────────────────────────────────────┐ 
│MENU  │DESCRIPTION                                                     │ 
├──────┼────────────────────────────────────────────────────────────────┤ 
│Option│Specifies options for splitting waveforms, changing sampling    │ 
│      │rates, and returning to Voice Editor II window.                 │ 
├──────┼────────────────────────────────────────────────────────────────┤ 
│Edit  │Specifies options for editing the waveform.  They are Save, Cut,│ 
│      │Paste, Fill, and Insert.                                        │ 
├──────┼────────────────────────────────────────────────────────────────┤ 
│Effect│Specifies options for creating sound effects.  They are Amplify,│ 
│      │Echo, Fade Out, Fade In, Pan Left-Right, and Pan Right-Left.    │ 
└──────┴────────────────────────────────────────────────────────────────┘ 
 
NOTE:  Only an uncompressed voice block can be displayed as a waveform. 
       A compressed voice file only allows you to modify the sampling 
       rate.  When modifying a stereo voice file, two waveforms are 



       displayed.  However, you cannot modify the right and left 
       channels individually. 
 
SELECTING A WAVEFORM 
 
You can select a portion of the waveform using the keyboard or the 
mouse.  When a portion of the waveform is selected, it will be 
highlighted. 
 
TO SELECT A PORTION OF THE WAVEFORM USING THE MOUSE 
 
1.  Clock on the waveform and hold down the left mouse button. 
 
2.  Drag the mouse to the portion of the waveform. 
 
3.  Release the left mouse button once the desired portion of the 
    waveform is selected. 
 
    The selected portion will be highlighted. 
 
TO SELECT A PORTION OF THE WAVEFORM USING THE KEYBOARD 
 
1.  Press <CTRL+B> once you have played the cursor on the waveform. 
 
2.  Press <CTRL+E> once you have selected the desired portion of the 
    waveform. 
 
The keys that can be used from moving the cursor are: 
┌────────────┬──────────────────────────────────────┐ 
│KEYS        │DESCRIPTION                           │ 
├────────────┼──────────────────────────────────────┤ 
│<TAB>       │Moves the cursor quickly to the right.│ 
├────────────┼──────────────────────────────────────┤ 
│<SHIFT+TAB> │Moves the cursor quickly to the left. │ 
├────────────┼──────────────────────────────────────┤ 
│<<>         │Moves the cursor slowly to the left.  │ 
├────────────┼──────────────────────────────────────┤ 
│<>>         │Moves the cursor slowly to the right. │ 
└────────────┴──────────────────────────────────────┘ 
 
If you know the time interval between the beginning and ending points, 
you can enter the time in the Blk Bgn and Blk End text boxes. 
 
SPLITTING A WAVEFORM 
 
To split a Waveform: 
 
1.  Select a splitting point on the waveform. 
 
2.  Select Split Block from the Option menu. 
 
    The portion of the waveform on the right disappears.  The split 
    waveform will be displayed in the Block Type Information window. 
    To view the split waveform, return to the Voice Editor II window 
    by selecting Exit from the Option menu. 
 
CHANGING WAVEFORM SAMPLING RATES 



 
To change the sampling rate of a waveform: 
 
1.  Select Edit Sampling Rate from the Option menu. 
 
    The Edit Sampling Rate dialog box appears. 
 
2.  Choose OK once the desired rate is selected. 
 
NOTE:  When you change the sampling rate of a selected portion of the 
       waveform, the voice block will change. 
 
SAVING A WAVEFORM 
 
To save a portion of the waveform: 
 
1.  Select the desired portion of the waveform. 
 
    The portion selected will be highlighted. 
 
2.  Select Save from the Edit menu. 
 
    The Save Data dialog box appears. 
 
3.  Enter the filename and the directory path accordingly. 
 
CUTTING A WAVEFORM 
 
To cut a portion of the waveform: 
 
1.  Select the desired portion 
 
    The portion selected will be highlighted. 
 
2.  Select cut from the Edit menu. 
 
    The portion cut is held in memory until it is pasted onto the 
    waveform. 
 
PASTING A WAVEFORM 
 
To paste the portion cut onto the waveform: 
 
1.  Select the position where you want to paste the waveform. 
 
2.  Select Paste from the Edit menu. 
 
    The portion cut will be inserted into the position selected. 
 
FILLING A WAVEFORM WITH SILENCE 
 
This command allows you to replace a selected portion of waveform with 
silence.  To fill a portion of the waveform: 
 
1.  Select the desired portion. 
 
2.  Select fill from the Edit menu. 



 
    The Fill dialog box appears.  Enter a value between 0 and 255.  The 
    default value is 128 (silence). 
 
3.  Enter the desired value. 
 
INSERTING A WAVEFORM WITH SILENCE 
 
This command allows you to insert silence into a selected portion of the 
waveform.  To insert a portion of the waveform with silence: 
 
1.  Select the desired portion. 
 
2.  Select Insert from the Edit menu. 
 
    The Insert dialog box appears.  Enter a value ranging from 0 to 255. 
    The default value is 128. 
 
3.  Enter the desired value. 
 
CREATING SPECIAL EFFECTS 
 
Special effects can be created using the commands on the Effect menu. 
The descriptions of the commands on the Effect menu are: 
 
┌───────────┬──────────────────────────────────────────────────────────┐ 
│OPTION     │DESCRIPTION                                               │ 
├───────────┼──────────────────────────────────────────────────────────┤ 
│Amplify    │Changes the volume level of the entire or a portion of the│ 
│           │waveform.  Displays dialog box prompting for the magnitude│ 
│           │of the volume in percentage.  The default value is 200%.  │ 
├───────────┼──────────────────────────────────────────────────────────┤ 
│Echo       │Adds echo effect to the waveform.  Displays a dialog box  │ 
│           │prompting for the percentage of the echo effect and the   │ 
│           │delay time.                                               │ 
├───────────┼──────────────────────────────────────────────────────────┤ 
│Fade Out   │Fades the current selection from 100% amplitude to silence│ 
│           │(0% amplitude).                                           │ 
├───────────┼──────────────────────────────────────────────────────────┤ 
│Fade In    │Fades the current selection from silence (0% amplitude) to│ 
│           │(100% amplitude).                                         │ 
├───────────┼──────────────────────────────────────────────────────────┤ 
│Pan        │Allows a selected portion of the waveform to move         │ 
│Left-Right │gradually from left to right speaker.  (Works only with   │ 
│           │stereo waveform.                                          │ 
├───────────┼──────────────────────────────────────────────────────────┤ 
│Pan        │Allows a selected portion of the waveform to move         │ 
│Right-Left │gradually from right to left speaker.  (Works only with   │ 
│           │stereo waveform).                                         │ 
└───────────┴──────────────────────────────────────────────────────────┘ 
 
RUNNING CD PLAYER 
 
If you have a CD-ROM drive installed, you can control the CD-audio using 
Voice Editor II. 
 
TO CONTROL THE CD-AUDIO 



 
1.  Select Cd Player from the CDisc menu. 
 
    The Compact Disc Control Screen appears. 
 
TO SET THE VOLUME OF THE CD-AUDIO 
 
1.  Select CDisc from the Volume menu. 
 
    The CD Volume dialog box. 
 
2.  Choose OK. 
 
QUITTING VOICE EDITOR 
 
To quit Voice Editor II: 
 
1.  Select Exit from the File menu in Voice Editor II window. 
 
WINDOWS 3.1 UTILITIES 
 
MULTIMEDIA JUKEBOX 
 
The utilities described in this chapter requires Microsoft Windows 3.1. 
To use these utilities, you need to have Microsoft Windows 3.1 installed 
on your system. 
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